If you are coming from Debian/Ubuntu you are probably used to install build-essential.
In CentOS they use the following command instead: